Page 1 of 1

Stuck at "Ask parameter server to set stereo mode ..."

Posted: Tue Apr 02, 2024 8:17 am
by ogrinj
Hi there,

This is Jan and I'm writing from company that purchased Scarlet 3D camera (25cm). Our goal is to use it on Jackal robot from Clearpath Robotics ( for depth estimation. The end goal is to use Nerian ROS node to publish image data but I initially wanted to test it using suggested scripts that come with Python API ( I had no issues with installation on both my laptop and Jackal computer and I also had no issue running all examples on my laptop successfully. Computer on Jackal robot doesn't have monitor so I didn't run "" script but I wanted to perform sanity check with "" just to save image acquired at one moment and here is where I got stuck. This is the output I got:

Found these devices:
1:; Scarlet; 3.4.0; compatible; N/A
Selected device #1
Ask parameter server to set stereo mode ...
Traceback (most recent call last):
File "", line 51, in <module>
File "./visiontransfer/visiontransfer_parameters_autogen.pyx", line 166, in visiontransfer.DeviceParameters.set_operation_mode
RuntimeError: Timeout waiting for parameter server ready state

i.e. stereo camera gets detected just fine but the script gets stuck in "Ask parameter server to set stereo mode ...". I wasn't able to find solution to it after "Googeling" or any existing similar topic on forum.

Any help/suggestion will be greatly appreciated .

Many thanks and kind regards,
Jan Ogrin

Re: Stuck at "Ask parameter server to set stereo mode ..."

Posted: Thu Apr 04, 2024 9:57 am
by k.schauwecker
Hi Jan,

this is indeed a strange behavior. The multi-cast network communication that we use for device enumeration worked, but creating a connection seems to fail.

First of all, you can delete lines 50 and 51 from the example and it should still work. What these two lines do is create a connection to our parameter API and then make sure that the device is set to stereo matching mode (which it should already be unless you changed the configuration).

Image data transport happens over a separate connection, that is created in line 54. However, when you remove lines 50 and 51, it might just fail there instead.

It could be a network configuration issue. Are jumbo frames enabled on the host PC (or are they disabled on Scarlet)? In the past we also had problems with various firewall software on windows (and restrictive iptables settings on linux). What OS is the PC using?

Could you test if our NVCom application runs correctly? If that computer does not have a screen, you can also launch NVCom without a GUI with the following command:

Code: Select all

nvcom -n -H
Then it will log the received FPS to the terminal.

Best regards,

Re: Stuck at "Ask parameter server to set stereo mode ..."

Posted: Fri Apr 05, 2024 1:55 pm
by ogrinj
Hi Konstantin,

first of all, thank you very much for answering my question because your suggestion that it might be network configuration issue solved my problem (also the issue regarding asking parameter server to set desired mode i.e. even if I didn't comment out lines 50 and 51). I'll write here what was actually the only thing I had to do in order to make it work so that it will potentially help anyone that might encounter the same issue.

Computer on our robot is using Linux OS and the only thing I had to do was enable jumbo frames. I did that using instructions from here:
From here all scripts work and I have no issue launching ros node.

I'm sure something very similar can be done on Windows.

Many thanks and kind regards,

Re: Stuck at "Ask parameter server to set stereo mode ..."

Posted: Mon Apr 08, 2024 9:45 am
by k.schauwecker
Hi Jan,

thank you for the update. I'm glad the issue is resolved.

Best regards,